e2comm

Members
  • Content Count

    4
  • Joined

  • Last visited

  1. Olá Pessoal, Como o Gdon disse acima realmente funciona com Localhost, tem muito gente falando aqui que o problema é porque o pessoal está usando Localhost e isso não procede, utilizem sem o https que vai funcionar. Mas enfim, outro detalhe que tive que alterar foi o seguinte, No arquivo Meli.php esta assim "CURLOPT_SSL_VERIFYPEER => true" coloquei para "False". Abraço.
  2. Mldev, Agradeço sua tentaiva de me ajudar mas o que você me falou não resolve meu problema, como tinha dito fiz o teste também utilizando o endereço https://www.meusite.com.br/e2sysadmin/ml_login/ml_login.phpe acontece o mesmo problema, então creio que este erro não é por causa da URL que é local ou pública. Sou novato no forum e li vários posts antes de colocar aqui minha dúvida e dificuldade, pelo que olhei nos outros posts o pessoal não apresenta a solução para os problemas é sempre assim, releia a documentação, creio que quem posta uma dúvida no Forúm já deve ter lido a documentação e tentado outras alternativas, como no meu caso. Espero que o Administrador possa me ajudar, segui os passos da documentação e estou utilizando o SDK mas não funciona. Aparentemente é um processo simples e deveria estar funcionando ainda mais porque estou utilizando exatamento o código do SDK. Se alguém puder me ajudar agradeço.
  3. MLdev, Eu encontrei diversos tópicos no Forum sobre problemas em conseguir o Token inclusive alguns dizendo que funciona normalmente com localhost sendo que o teste está sendo feito no ambiente de desenvolvimento. Também testei publicando em meu servidor utilizando a URL de produção e acontece o mesmo problema. Se você diz que não funciona com o localhost pode me explicar como temos que desenvolver a integração com a API do ML ? Preciso de um servidor web com uma URL www.minhaaplicacao.com.br ? Desculpe minha insistência mas não consigo compreender como fazer para testar ou debugar sem ser em localhost. Grato
  4. Olá Pessoal, Baixei os arquivos da SDK em php e fiz as configurações conforme informado na documentação, registrei minha aplicação para conseguir o App ID e o Secret Key. Até o momento segui os seguintes passos. 1 - Baixei o SDK e configurei o arquivo Meli.php na minha aplicação; 2 - Coloquei meu App ID e Secret Key no código abaixo; 3 - Inclui o CURLOPT_SSLVERSION => 2 no arquivo Meli.php; Quando executo minha aplicação e clico no link para logar no Mercado Livre, é feito o processo de login na página do ML, o sistema redireciona para minha aplicação com o "Code" na URL, eu resgato o "Code" e envio para o método "authorize" ($user = $meli->authorize($_GET['code'], 'https://localhost/v8/app/padrao/ml_login/ml_login.php'Meli::$AUTH_URL['MLB']) . '">Login using MercadoLibre oAuth 2.0</a>'; }