BEM__BARATO

Members
  • Content Count

    3
  • Joined

  • Last visited

About BEM__BARATO

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Seguinte, tenho um produto cadastrado de um cliente, id MLB860126623 Hoje o anúncio está cadastrado sem variação, mas quero criar variação nele Logo então, segundo a documentação, posso realizar um post em items/MLB860126623/variations ou um PUT no items/MLB860126623 Já tentei pelas 2 formas e sempre dá problema. Um deles que tenho aqui como exemplo foi o put em /items/MLB860126623 Enviando o seguinte json: { "variations": [ { "seller_custom_field": "75", "picture_ids": [ "853832-MLB28386544909_102018", "719727-MLB27657891950_062018", "790646-MLB27657891949_062018" ], "available_quantity": 97, "price": 21.17, "attribute_combinations": [ { "id": "COLOR", "value_id": "1", "value_name": "PRETO" } ] } ] } E o retorno que tenho é sempre o mesmo: { "message": "Validation error", "error": "validation_error", "status": 400, "cause": [ { "department": "items", "cause_id": 157, "type": "error", "code": "item.variations.attribute_combinations.missing", "references": [ "item.variations[0].attribute_combinations" ], "message": "You cannot create a variation without attribute_combinations." } ] } O que me dizem sobre isso? Por que não consigo cadastrar uma variação via API e no painel do próprio Mercado Livre eu consigo?
  2. valeu amigo, dessa forma resolveu o problema, temporariamente.. agora o problema é que não sabemos até quando vai continuar funcionando assim...
  3. Bom dia pessoal Desde hoje cedo a API de impressão de etiquetas parou de funcionar, já consegui imprimir normal via tela do Mercado Livre, porém sem sucesso na API, não foi mexido nada, apenas parou de funcionar :( A url que uso para impressão de etiquetas é essa: https://api.mercadolibre.com/shipment_labels?shipment_ids=xxxxxxxxxxxxx&access_token=APP_USR-XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX O Erro que me retorna é esse: {"error":"ERROR in api: shipment_labels","message":"status: 400 - message: Error in Shipping API - Invalid User. BAD REQUEST USERS: /users/null?caller.id=null&client.id=1360974954364596 - HTTP/1.1 400 Bad Request","status":400} Alguém mais ai sofrendo o mesmo problema? é algo no ML mesmo ou estou fazendo requisição não mais válida?