lfcardoso

Members
  • Content Count

    8
  • Joined

  • Last visited

  • Days Won

    2
  1. Acredito que eu descobri o erro. O parâmetro correto para se pegar as questões ja respondidas do usuário é o from. ficando assim: $getHistoricoQuestao = $meli->get('/questions/search', array('status' => 'answered', 'item_id' => $prodInfo['id'], 'from' => $userResult['id'], 'access_token' => $_SESSION['access_token'])); Eu estava colocando seller_id é esse é do vendedor. Desculpas pelo incomodo.
  2. Bom dia! Alguém sabe como faz para puxar as perguntas anteriores que o cliente fez referente ao mesmo produto? Igual é no mercado livre hj, mas preciso fazer isso via API. Eu tentei: $getHistoricoQuestao = $meli->get('/questions/search', array('status' => 'answered', 'item_id' => $prodInfo['id'], 'seller_id' => $userResult['id'], 'access_token' => $_SESSION['access_token'])); Mas da o seguinte erro: Array ( [body] => stdClass Object ( [message] => Action not allowed. [error] => action_not_allowed [status] => 403 [cause] => Array ( ) ) [httpCode] => 403 )
  3. Preciso que retorne todos os produtos que tem perguntas não respondidas. Fiz da seguinte maneira: - Pego todos os itens do Usuarios - Depois tento retornar todas as perguntas conforme o codigo de itens. So que esta retornando todos os itens. Existe alguma maneira? Segue o codigo abaixo: $infoItem = $meli->get('/users/'.$getUser['id'].'/items/search', array('status' => 'active', 'access_token' => $_SESSION['access_token'])); $resultItem = get_object_vars($infoItem['body']); foreach ($resultItem['results'] as $key => $idItem) { //buscando questões em aberto conforme o item $infoQuestoes = $meli->get('/questions/search/', array('item_id' => $idItem, 'status' => 'UNANSWERED', 'access_token' => $_SESSION['access_token'])); $getQuestoes = get_object_vars($infoQuestoes['body']); }
  4. Qual é a url de callback que esta definido nas configurações do ML? Pelo erro esta dizendo que a sua url de callback tem que ser igual ao redirect_url
  5. Pela imagens na classe esta como nome do arquivo validatetoken e na pagina do configuração do ML esta ValidateToken, ou seja, um tudo minusculo e outro com as iniciais maiúsculas. Tente deixar tudo igual, em um padrão só ou tudo minusculo ou maiúsculo. Eu acho que pode ser isso.
  6. Meu somente deu certo depois que eu deixei o CURLOPT_SSL_VERIFYPEER => false Agora não sei se pode, mas pelo menos a função do refresh_token funciona
  7. Estou com o mesmo problema, a versão do meu SSL é 1 e a função do refresh_token retorna em branco.