• 0
Sign in to follow this  
Diego A. Boscan

No recibo notificaciones

Question

Hola, espero que esten muy bien. Tengo mi aplicacion web en un servidor, y con su ruta configurada para recibir un POST.

La ruta para recibirlas es un POST que retorna un status 200, tal como lo pide la API.

Si hago la peticion desde mi maquina funciona, pero aparentemente desde ML no les funciona, esto es lo que me da el recurso 'myfeeds':

"messages": [
        {
            "_id": "59c95fba35e9270a208a213d",
            "resource": "/items/MLU448775053",
            "user_id": 273488706,
            "topic": "items",
            "application_id": XXXX,
            "attempts": 1,
            "sent": "2017-09-25T19:57:46.129Z",
            "received": "2017-09-25T19:57:46.106Z",
            "request": {
                "url": "XXX",
                "headers": {
                    "accept": "application/json",
                    "content-type": "application/json",
                    "content-length": 189
                },
                "data": "{\"resource\":\"/items/XX\",\"user_id\":273488706,\"topic\":\"items\",\"application_id\":XXX,\"attempts\":1,\"sent\":\"2017-09-25T19:57:46.129Z\",\"received\":\"2017-09-25T19:57:46.106Z\"}"
            },
            "response": {
                "req_time": 426,
                "http_code": 301,
                "body": "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>301 Moved Permanently</title>\n</head><body>\n<h1>Moved Permanently</h1>\n<p>The document has moved <a href="xxxx">here</a>.</p>\n<hr>\n<address>Apache/2.2.15 (CentOS) DAV/2 PHP/7.1.9 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips Server at xxxxx.com Port 443</address>\n</body></html>\n",
                "headers": {
                    "date": "Mon, 25 Sep 2017 19:57:45 GMT",
                    "server": "Apache/2.2.15 (CentOS) DAV/2 PHP/7.1.9 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips",
                    "location": "xxxx",
                    "vary": "Accept-Encoding",
                    "content-length": "405",
                    "connection": "close",
                    "content-type": "text/html; charset=iso-8859-1"
                }
            }
        },

 

Edited by Diego A. Boscan

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this