• 0
jorge lujan medina

El método get de Meli no me retorna nada

Question

Estoy utilizando este código para a

require '../Meli/meli.php';
require '../configApp.php';
$meli = new Meli($appId, $secretKey);
$params = array();
$url = '/sites/' . $siteId;
$result = $meli->get($url, $params);
echo '<pre>';
print_r($result);
echo '</pre>';

Y he probado la llamada a https://api.mercadolibre.com/sites con el comando curl en línea de comandos y funciona perfectamente.
Tengo instalacdo un apache 2.4.28 con el módulo fcgid 2.3.9, todo x64bits. Con un php 5.6.38 con el módulo curl.dll que viene de fábrica.
Me pueden ayudar con eso?

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

A  mi me resulto lo siguiente:

 

Para que funcione el example_get.php se debe entrar al meli.php y editar lo siguiente:

 

public static $CURL_OPTS = array(
        CURLOPT_USERAGENT => "MELI-PHP-SDK-1.1.0", 
        CURLOPT_SSL_VERIFYPEER => true,
        CURLOPT_CONNECTTIMEOUT => 10, 
        CURLOPT_RETURNTRANSFER => 1, 
        CURLOPT_TIMEOUT => 60
    );

 

Se debe cambiar el "CURLOPT_SSL_VERIFYPEER => true" por "CURLOPT_SSL_VERIFYPEER => false" (sin las comillas ").

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now