• 0
Sign in to follow this  
Fernando Martin

Error en validacion de producto

Question

Hola!

Estoy desarrollando una aplicacion utilizando el SDK para PHP. Necesito publicar vehículos en el sitio de Argentina, y para eso estoy intentando, antes de realizar la publicacion, validar el objeto a publicar.

El problema con el que me encuentro es que envío un objeto al validador y me devuelve el siguiente resultado:

array(2) {
  ["body"]=>
  NULL
  ["httpCode"]=>
  int(400)
}

Está claro que no valida correctamente por el codigo 400, lo que no entiendo es por qué me llega el campo "body" en NULL, en lugar de los errores de validación del posteo.

El objeto que estoy enviando a la url "items/validate" es el siguiente:

array(9) {
  ["site_id"]=>
  string(3) "MLA"
  ["title"]=>
  string(46) "ITEM DE TEST"
  ["category_id"]=>
  string(8) "MLA27433"
  ["price"]=>
  string(6) "192000"
  ["currency_id"]=>
  string(3) "ARS"
  ["available_quantity"]=>
  int(1)
  ["listing_type_id"]=>
  string(4) "free"
  ["condition"]=>
  string(4) "used"
  ["automatic_relist"]=>
  bool(false)
}

Cualquier ayuda será bienvenida!

Desde ya muchas gracias!

F

 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this