• 0
pedro.bini

Erro na atualização de alguns atributos

Question

Olá pessoal,

Notamos que existe um bug na API do Mercado Livre, onde ao atualizar os atributos BRAND e MODEL de qualquer item, o mesmo não é atualizado (nem mesmo pelo painel do Mercado Livre!).

Para atualizá-los, precisamos primeiro enviar um PUT com a lista de atributos vazia, depois inserir todos os atributos novamente.

Lembrando que de acordo com nossos testes, encontramos problemas apenas nestes dois, porém podem existir outros.

 

Att.

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0
4 hours ago, pedro.bini said:

Olá pessoal,

Notamos que existe um bug na API do Mercado Livre, onde ao atualizar os atributos BRAND e MODEL de qualquer item, o mesmo não é atualizado (nem mesmo pelo painel do Mercado Livre!).

Para atualizá-los, precisamos primeiro enviar um PUT com a lista de atributos vazia, depois inserir todos os atributos novamente.

Lembrando que de acordo com nossos testes, encontramos problemas apenas nestes dois, porém podem existir outros.

 

Att.

também notamos esse problema

Share this post


Link to post
Share on other sites
  • 0

Alguma novidade do time do Mercado Livre ou previsão para reparo?

Gambiarras na API do Mercado Livre são comuns, agora temos que fazer nos nossos sistemas também para poder funcionar.

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, pedro.bini said:

Alguma novidade do time do Mercado Livre ou previsão para reparo?

Gambiarras na API do Mercado Livre são comuns, agora temos que fazer nos nossos sistemas também para poder funcionar.

o pessoal do ML não tem entrado mais no fórum (pelo menos faz muuuito tempo que nenhum deles posta nada aqui), da nossa parte já desistimos de contactar o suporte porque nunca nada é resolvido, como eu disse em outro tópico, a empresa aqui já deixou de lado o desenvolvimento de funcionalidades para integração com Mercado Livre pois od jeito que está fica inviável (fora o descontentamento enorme dos vendedores em relação ao ML)

Share this post


Link to post
Share on other sites
  • 0

Até dias atras, estava consultando por API o SKU, de boa...hoje, retorna NULL, mesmo tendo cadastrado no item.

Será que tem relação com este bug citado no topico?

Ou tem relação com o perda de medalha ou algo assim? Nem no editar produto, ele aparece.

Abraço

Mauro

Edited by mauroagr
erro escrita

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, mauroagr said:

Até dias atras, estava consultando por API o SKU, de boa...hoje, retorna NULL, mesmo tendo cadastrado no item.

Será que tem relação com este bug citado no topico?

Ou tem relação com o perda de medalha ou algo assim? Nem no editar produto, ele aparece.

Abraço

Mauro

não vou saber informar pois não controlamos por aqui baseado no campo de seller_custom_field (onde o ML guardava o SKU), pois sempre tivemos um pé atrás com isso...

mas eu arrisco um palpite, pode ser que esteja relacionado com o novo identificador, o SELLER_SKU

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, mldev said:

não vou saber informar pois não controlamos por aqui baseado no campo de seller_custom_field (onde o ML guardava o SKU), pois sempre tivemos um pé atrás com isso...

mas eu arrisco um palpite, pode ser que esteja relacionado com o novo identificador, o SELLER_SKU

Possivelmente seja este seller_sku, porém como que faço para buscar os produtos baseados no atributo, via API?
Acho que vou ter de criar um banco de dados para gravra qual o ID do ML...com o meu SKU....mas é complicar a vida por uma coisa tão simples.

Obrigado.

Share this post


Link to post
Share on other sites
  • 0
34 minutes ago, mauroagr said:

Possivelmente seja este seller_sku, porém como que faço para buscar os produtos baseados no atributo, via API?
Acho que vou ter de criar um banco de dados para gravra qual o ID do ML...com o meu SKU....mas é complicar a vida por uma coisa tão simples.

Obrigado.

aqui nós controlamos pelo nosso DB, pois já tivemos muitos problemas com a API (entre eles uma época tiveram SKUs que simplesmente sumiam, entre outros dados como rastreios e etc)

Share this post


Link to post
Share on other sites
  • 0
50 minutes ago, mldev said:

aqui nós controlamos pelo nosso DB, pois já tivemos muitos problemas com a API (entre eles uma época tiveram SKUs que simplesmente sumiam, entre outros dados como rastreios e etc)

É complica a vida de pedreiro digital...mas vamos mudar o jeito que faço e ir levando a vida. Depende de mktplace é pra quebrar

Share this post


Link to post
Share on other sites
  • 0

Que legal o ML.

Modifiquei tudo na minha classe, e agora retorna no update do item put('/items/'.$idML, $xml_update, $this->params);

Alguem tem ideia do que possa ser o erro abaixo?

  [body] => stdClass Object
        (
            [message] => The caller is not authorized to access this resource
            [error] => forbidden
            [status] => 403
            [cause] => Array
                (
                )

        )

    [httpCode] => 403
)

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, mauroagr said:

Que legal o ML.

Modifiquei tudo na minha classe, e agora retorna no update do item put('/items/'.$idML, $xml_update, $this->params);

Alguem tem ideia do que possa ser o erro abaixo?


  [body] => stdClass Object
        (
            [message] => The caller is not authorized to access this resource
            [error] => forbidden
            [status] => 403
            [cause] => Array
                (
                )

        )

    [httpCode] => 403
)

Mauro,

 

Acredito que sua access_token está inválida ou não foi adicionada na URL.

 

Att.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, mauroagr said:

Que legal o ML.

Modifiquei tudo na minha classe, e agora retorna no update do item put('/items/'.$idML, $xml_update, $this->params);

Alguem tem ideia do que possa ser o erro abaixo?


  [body] => stdClass Object
        (
            [message] => The caller is not authorized to access this resource
            [error] => forbidden
            [status] => 403
            [cause] => Array
                (
                )

        )

    [httpCode] => 403
)

não está utilizando o access_token de um usuário para tentar acessar o item de outro?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now