• 0
Sign in to follow this  
Pablo1974

Imposible Crear Usuario de Prueba

Question

Les escribo ya que el soporte que da Mercadolibre es pesimo, estoy intentando crear usuarios de test de la manera que dice en la siguiente URL:

https://developers.mercadolibre.com/es_ar/realiza-pruebas#compra-vende

Y a pesar de probar de varias maneras no hay caso, no los crea, intento hacerlo usando la clase Meli:

$params = array('access_token'=>$accessToken,'site_id'=>"MLA");
$result = $meli->post('/users/test_user',null, $params);

Incluso probé de otras maneras y siempre el mismo error:

a:2:{s:4:"body";O:8:"stdClass":4:{s:7:"message";s:14:"Invalid siteId";s:5:"error";s:11:"bad_request";s:6:"status";i:400;s:5:"cause";a:0:{}}s:8:"httpCode";i:400;}

Cuando voy a lo seguro y voy a ver la URL de Base:

https://api.mercadolibre.com/users/test_user

Me dice que la pagina no existe, como es que se soluciona esto? alguien sabe?

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
On 8/14/2018 at 9:09 AM, Pablo1974 said:

Les escribo ya que el soporte que da Mercadolibre es pesimo, estoy intentando crear usuarios de test de la manera que dice en la siguiente URL:

https://developers.mercadolibre.com/es_ar/realiza-pruebas#compra-vende

Y a pesar de probar de varias maneras no hay caso, no los crea, intento hacerlo usando la clase Meli:


$params = array('access_token'=>$accessToken,'site_id'=>"MLA");
$result = $meli->post('/users/test_user',null, $params);

Incluso probé de otras maneras y siempre el mismo error:

a:2:{s:4:"body";O:8:"stdClass":4:{s:7:"message";s:14:"Invalid siteId";s:5:"error";s:11:"bad_request";s:6:"status";i:400;s:5:"cause";a:0:{}}s:8:"httpCode";i:400;}

Cuando voy a lo seguro y voy a ver la URL de Base:

https://api.mercadolibre.com/users/test_user

Me dice que la pagina no existe, como es que se soluciona esto? alguien sabe?

 

Te muestro como yo lo hago:

$meli = new Meli('APP_ID', 'SECRET_KEY');
$params = array('access_token' => 'access_token');
$body = array('site_id' => 'MLA');
$response = $meli->post('/users/test_user', $body, $params);

Creo el error es tu "null". Espero te sirva, Saludos.

Share this post


Link to post
Share on other sites
  • 0

Siiii, ahora si funciona, muchas gracias por el aporte, en ningún lado explica con detalle este punto y algo tan sencillo retrasa tanto.

 

Muchas gracias nuevamente

Share this post


Link to post
Share on other sites
  • 0

 

Hola buenos días.

Consulta: ¿Es posible crear un usuario de test que sea monotributista o responsable inscripto? Hasta ahora solamente pude crear usuarios finales.

Gracias.

Mario.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this