• 0
Pablo1974

Cambiar status de producto con error Clase Meli

Question

Escribo despues de probar y recorrer varias paginas. Estoy tratando de cambiar el Estado de un producto, el cual está activo y lo quiero pasar a pausado, entonces hago esto en mi codigo:

 

$params = array('access_token'=>$accessToken);
$body = array("status" => "paused");
$result = $meli->put('/items/'.$idProducto,$body, $params);

Pero por mas que pruebe de distintas manera me tira el mensaje:

 

The caller is not authorized to access this resource

 

y no se porqué ya que estoy bien autenticado, ya no sé donde buscar, por favor alguien sabe porqué puede estar pasando esto?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
16 hours ago, Pablo1974 said:

Escribo despues de probar y recorrer varias paginas. Estoy tratando de cambiar el Estado de un producto, el cual está activo y lo quiero pasar a pausado, entonces hago esto en mi codigo:

 


$params = array('access_token'=>$accessToken);
$body = array("status" => "paused");
$result = $meli->put('/items/'.$idProducto,$body, $params);

Pero por mas que pruebe de distintas manera me tira el mensaje:

 

The caller is not authorized to access this resource

 

y no se porqué ya que estoy bien autenticado, ya no sé donde buscar, por favor alguien sabe porqué puede estar pasando esto?

Valida que el propietario del token sea el mismo propietaro de dicha publicación. Ese mensaje aparece cuando se intenta modificar una publicación que no pertenece a dicho usuario (token de dicho usuario).

Share this post


Link to post
Share on other sites
  • 0
On 8/28/2018 at 7:19 AM, Woomelly said:

Valida que el propietario del token sea el mismo propietaro de dicha publicación. Ese mensaje aparece cuando se intenta modificar una publicación que no pertenece a dicho usuario (token de dicho usuario).

Muchas gracias por el dato! el error venía por ahí, me estaba logeando como desarrollador en vez de como el cliente, ahora si anda.

Igual, no se si es otro error aparte pero a cada rato me da error de conexion con el httpCode = 0, eso es normal?

Share this post


Link to post
Share on other sites
  • 0
On 8/30/2018 at 10:33 PM, Pablo1974 said:

Muchas gracias por el dato! el error venía por ahí, me estaba logeando como desarrollador en vez de como el cliente, ahora si anda.

Igual, no se si es otro error aparte pero a cada rato me da error de conexion con el httpCode = 0, eso es normal?

Puede que sea el servidor pero si usas PHP observa cual es el error real que te envia en el CURL (es decir, entra al SDK y temporalmente colocale un print_r en el CURL y te podras guiar). Saludos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now