• 0
Fernando Rodrigo

publicação de produto

Question

Estou começando a fazer a publicação de produtos em delphi, estou passando os parametros e Json conforme abaixo, so que esta sempre retornando erro

 

https://api.mercadolibre.com/items?access_token=XXXXXXXXXX

Segue abaixo o json passado

{"title":"KIT BUCHAS CAIXA DIRECAO",  "category_id":"MLA5529" ,  "prince":4.26,  "official_store_id":1,   "currency_id":"ARS",   "available_quantity":11,  "buying_mode":"buy_it_now",   "listing_type_id":"gold_pro",  "condition":"new",  "description":"DK: DKTB4609'#$D#$A'KITCIA: KIT10119'#$D#$A'KITSBOR: KTB4030469'#$D#$A'OEM: 7073183",  "pictures":[ {"source":"http://177.43.90.227/KIT10119.jpg"},{"source":"http://177.43.90.227/KIT10119-1.jpg"},{"source":""}] ,  "attributes":[{ "id":"EAN","value_name":"7899470217581"}]}


HTTP/1.1 400 Bad Request
 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
4 hours ago, Fernando Rodrigo said:

Estou começando a fazer a publicação de produtos em delphi, estou passando os parametros e Json conforme abaixo, so que esta sempre retornando erro

 

https://api.mercadolibre.com/items?access_token=XXXXXXXXXX

Segue abaixo o json passado

{"title":"KIT BUCHAS CAIXA DIRECAO",  "category_id":"MLA5529" ,  "prince":4.26,  "official_store_id":1,   "currency_id":"ARS",   "available_quantity":11,  "buying_mode":"buy_it_now",   "listing_type_id":"gold_pro",  "condition":"new",  "description":"DK: DKTB4609'#$D#$A'KITCIA: KIT10119'#$D#$A'KITSBOR: KTB4030469'#$D#$A'OEM: 7073183",  "pictures":[ {"source":"http://177.43.90.227/KIT10119.jpg"},{"source":"http://177.43.90.227/KIT10119-1.jpg"},{"source":""}] ,  "attributes":[{ "id":"EAN","value_name":"7899470217581"}]}


HTTP/1.1 400 Bad Request
 

A principio nao parece ter erro no json ai se isso for uma inclusao

Isso é uma inclusão ? ta fazendo via post ? ta usando tidhttp ou trest... ?

Share this post


Link to post
Share on other sites
  • 0
46 minutes ago, gbandoni said:

A principio nao parece ter erro no json ai se isso for uma inclusao

Isso é uma inclusão ? ta fazendo via post ? ta usando tidhttp ou trest... ?

fazendo inclusão, post e idhttp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now