Question

10 answers to this question

Recommended Posts

  • 0

found the problem in other POST

http://developers-forum.mercadolibre.com/index.php?/topic/714-api-meli-php/?hl=ssl3#entry3119

 

your PHP configuration by default use SSL 3 and is deprecated by an security bridge found by google 

 

set the default ssl opt on the meli.php 

curl_setopt ($ch, CURLOPT_SSLVERSION, 2);

 

Regards

Share this post


Link to post
Share on other sites
  • 0

Estou tendo o mesmo problema e não estou conseguindo resolver. Seguem as etapas:

1) Baixei o SDK numa pasta do meu servidor local;

2) Criei uma aplicação no APP Manager e coloquei no campo Redirect URI: http://localhost/ML/examples/example_login.php. Obtive APP ID e o Secret Key;

3) Alterei o example_login.php, colocando o APP ID e o Secret Key.

4) Alterei o meli.php, inserindo na linha 23 CURLOPT_SSLVERSION => 2,

 

O problema continua. O que estou fazendo de errado?

Share this post


Link to post
Share on other sites
  • 0

the problem is the CRUL options 

public static $CURL_OPTS = array(   CURLOPT_USERAGENT => "MELI-PHP-SDK-1.0.0",   CURLOPT_SSL_VERIFYPEER => true,   CURLOPT_CONNECTTIMEOUT => 10,   CURLOPT_RETURNTRANSFER => 1,  

CURLOPT_TIMEOUT => 60,

CURLOPT_SSLVERSION => 2,

  );

 

 

this works for me, can you make a try catch and get the error with more details?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...